Search found 76 matches

by jbuffethed
Mon Apr 24, 2006 8:14 am
Forum: XR4Ti
Topic: BOV help
Replies: 19
Views: 7421

Image
by jbuffethed
Thu Oct 20, 2005 11:46 am
Forum: Off-Topic Discussion
Topic: Ummmm.
Replies: 4
Views: 3588

Ummmm.

This was on MSNBC's site this morning LMAO


Image
by jbuffethed
Wed Oct 05, 2005 11:13 am
Forum: XR4Ti
Topic: I need heat
Replies: 10
Views: 3336

Sweet thanks alot guys. This 4"s of snow we got last night isnt helping me. Kinda fun to drive in the snow with this car.
by jbuffethed
Tue Oct 04, 2005 8:22 pm
Forum: XR4Ti
Topic: I need heat
Replies: 10
Views: 3336

I got it out, but I cant read the part #. Anyone got it?
by jbuffethed
Mon Oct 03, 2005 10:41 pm
Forum: XR4Ti
Topic: I need heat
Replies: 10
Views: 3336

What does this resistor pack look like? So I can kick its ass, picked the best time to crap out. Got snow in the forcast this week
by jbuffethed
Mon Oct 03, 2005 1:46 pm
Forum: XR4Ti
Topic: I need heat
Replies: 10
Views: 3336

I need heat

My heater switch was only working only on hi, both recycled and fresh. The other day it quit all together. I really need this heat, it gets freakin cold up here and soon. How would I go about troubleshooting this? All fuses are good at the box, unless there are others under the dash Also, my passeng...
by jbuffethed
Sun Oct 02, 2005 10:21 am
Forum: XR4Ti
Topic: Injector ?
Replies: 6
Views: 2506

My gauge either never moves or takes forever. I am gonna pick up an autometer pretty soon. Seems like it takes a while to get to temp, but when it does it smells like burnt coolant. It has a new thermostat too, and the radiator is pretty new.
by jbuffethed
Sun Oct 02, 2005 1:07 am
Forum: XR4Ti
Topic: Injector ?
Replies: 6
Views: 2506

Injector ?

I took my intake off to see if I had a clog, cause my temp gauge is really responding. So i pull the fuel rail and notice I have 2 brown tops and 2 green. Is really a big problem?
by jbuffethed
Sat Oct 01, 2005 4:25 pm
Forum: General Discussion & Intro Forum
Topic: Florida
Replies: 9
Views: 3259

Yeah, I am from Tampa, but am stationed in ND. I there are only maybe 3-4 that I know of up here.
by jbuffethed
Sat Oct 01, 2005 1:50 pm
Forum: General Discussion & Intro Forum
Topic: Florida
Replies: 9
Views: 3259

This one is in Tampa. I'd go look at it if I still lived there. 87 Merkur XR4TI For sale Posting for my brother. He has a 1987 Comp shell Merkur XR4TI Turbo 2.3 For sale. Car has 97k Original Miles. Body and Paint are near flawless for being a 87'. Engine: Ford Motor sport Cam. Ford Motor sport Valv...
by jbuffethed
Wed Sep 14, 2005 9:36 pm
Forum: XR4Ti
Topic: mystery break leak
Replies: 6
Views: 2221

So I want the "with power brakes "option? I found a reman. @ NAPA for $72
by jbuffethed
Wed Sep 14, 2005 1:10 pm
Forum: XR4Ti
Topic: mystery break leak
Replies: 6
Views: 2221

I am having the same problem. BAM its dry, I fill it back up and the next morning I have a huge puddle. Looks like its coming off the MC or Booster, and there was signs of it on the hose that goes to the check valve. Where can I get a new MC or are there rebuild kits? And will the booster be damaged...
by jbuffethed
Wed Sep 14, 2005 9:26 am
Forum: FAQ - Frequently Asked Questions
Topic: valve cover gasket
Replies: 47
Views: 51077

So are those gaskets in that link the right ones?
by jbuffethed
Tue Sep 13, 2005 6:18 pm
Forum: FAQ - Frequently Asked Questions
Topic: valve cover gasket
Replies: 47
Views: 51077

Any one see this site before. Its got a few things http://www.500ms.net/2.3Ford.htm
by jbuffethed
Sat Sep 10, 2005 5:47 pm
Forum: XR4Ti
Topic: So I FINALLY ran some codes
Replies: 3
Views: 1552

I ran the codes, adjusted it to .94, then ran them again. I think it is turned all the way to the left and its at .94, Id have to double check