Changed my valve cover gasket now no boost

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
Post Reply
2manytickets
Level 2
Level 2
Posts: 185
Joined: Mon Aug 23, 2010 9:26 am

Changed my valve cover gasket now no boost

Post by 2manytickets » Sat Sep 18, 2010 11:22 pm

I really need some help i swapped out my valve cover gasket now i put everything back together and im getting 0 boost. Gauge goes to 0 and stops. I made sure everything was hooked up and vacum lines are good. Any help would be great.

User avatar
DPDISXR4Ti
Site Admin
Posts: 13474
Joined: Wed Jan 08, 2003 11:40 pm
Location: New York

Post by DPDISXR4Ti » Sun Sep 19, 2010 9:24 am

You do realize there's no relation between a valve cover gasket change and boost pressure, yes?
Brad

User avatar
Mike McCreight
Level 7
Level 7
Posts: 3979
Joined: Fri Oct 31, 2003 8:44 pm
Location: Ottawa! Well, Manotick, actually...

Post by Mike McCreight » Sun Sep 19, 2010 9:55 am

X2
Start by checking to see if your wastegate arm is still connected.
It's not a hobby, it's an obsession!

2manytickets
Level 2
Level 2
Posts: 185
Joined: Mon Aug 23, 2010 9:26 am

Post by 2manytickets » Sun Sep 19, 2010 10:25 am

i relizie there is no relation hence the confusion all i know is that it worked before i did it and now it dosnt

2manytickets
Level 2
Level 2
Posts: 185
Joined: Mon Aug 23, 2010 9:26 am

Post by 2manytickets » Sun Sep 19, 2010 10:38 am

wow im retarted i guess turbos work better when the wastegate arm is hooked up is there supposed to be a clip or somthing there

User avatar
Esteban
Level 7
Level 7
Posts: 1980
Joined: Wed Mar 24, 2010 2:07 am
Location: San Diego

Post by Esteban » Sun Sep 19, 2010 1:26 pm

Yes, there should be an e-clip there. Not sure what size though.

User avatar
Mike McCreight
Level 7
Level 7
Posts: 3979
Joined: Fri Oct 31, 2003 8:44 pm
Location: Ottawa! Well, Manotick, actually...

Post by Mike McCreight » Sun Sep 19, 2010 3:41 pm

I knew it... :wink:
I argued with those clips for a while, then I figured out how to hit the canister down with the butt of a hammer.
That'll angle the arm up enough that the arm won't fall off when that blessed clip does.
It's not a hobby, it's an obsession!

85xr
Level 2
Level 2
Posts: 158
Joined: Sat Oct 04, 2008 7:18 am
Location: dayton oh

Post by 85xr » Sun Sep 19, 2010 5:05 pm

when i bought my DD, the PO had an alligator clip on the accuator rod. :shock:
greg

2manytickets
Level 2
Level 2
Posts: 185
Joined: Mon Aug 23, 2010 9:26 am

Post by 2manytickets » Sun Sep 19, 2010 5:07 pm

these damn things are way funner with a turbo anyone know that :D

Post Reply