Just got it today

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
Merkur Club web site
abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Just got it today

Post by abomb1982 » Sat Mar 05, 2016 4:53 pm

Image

It has a long way to go but I thought It would be fun to have permanent timeline of the life and transformation of my new toy. My loose plan Is 300hp track suspension and making it look hot. I hope you all enjoy and I am always open to advice.

thesameguy
Level 7
Level 7
Posts: 2252
Joined: Mon Apr 18, 2005 5:06 pm
Location: Sacramento
Contact:

Re: Just got it today

Post by thesameguy » Sat Mar 05, 2016 5:47 pm

Looks like a solid place to start! :cheers

JimG
Level 5
Level 5
Posts: 540
Joined: Sat Jan 18, 2003 8:30 pm
Location: Waterford, Virginia

Re: Just got it today

Post by JimG » Sat Mar 05, 2016 5:58 pm

Welcome! Where are you located? Looks like you still have a lot of snow on the ground! Tell us more about your new ride!
Jim Gosses
86 XR4TI, 165K, T-5, IC, RR, PBR Fronts, T-bird Rear Discs
Image

User avatar
merkurdriver
Level 8
Posts: 6120
Joined: Tue Jan 21, 2003 4:29 pm
Location: Northeast Ohio
Contact:

Re: Just got it today

Post by merkurdriver » Sat Mar 05, 2016 6:36 pm

Welcome! :cheers

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Sun Mar 06, 2016 12:06 am

Its a 1985 with 96,000 miles, It has almost no rust :cheers
It turns over but does not start.
lowered front end but the guy was to lazy????????? to do the back?????????????
it came with the lowering springs and kyb shocks for the rear and a new/used turbo
there is a lot of wiring issues :(
I live in Michigan.

User avatar
eaton53
Level 5
Level 5
Posts: 643
Joined: Wed May 06, 2015 6:08 am
Location: Silvis, IL

Re: Just got it today

Post by eaton53 » Mon Mar 07, 2016 7:16 am

abomb1982 wrote:lowered front end but the guy was to lazy????????? to do the back?????????????
I guess he wanted some rake.
Or he lost interest halfway through.
Mark Copeland - I'm 50 miles west of Kewanee, IL

'89 XR4Ti
Car was the 2014 MCA Merkur Preservation Award Winner
Proud member of the Iowa-Illinois Merkur Owner's Association since 2015. :cheers

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Mon Mar 07, 2016 10:50 am

So I have soldered all the broken (chewed threw) wires I could find and have moved on to the fuel pump. I Am going to make sue that 12 volts are at least getting to the inline pump but in my preparing for changing it out I called the auto parts shop to get pricing. They said there is an in tank and an inline pump. Does this car have an in tank pump?

User avatar
Bob Weir
Membership Coordinator
Posts: 1059
Joined: Tue Oct 14, 2003 6:49 pm
Location: Allentown PA

Re: Just got it today

Post by Bob Weir » Mon Mar 07, 2016 12:41 pm

Welcome

You are eligible for a FREE 1 year membership!

Bob Weir
Membership Coordinator
BWeir4u@rcn.com

For more info, go here > viewtopic.php?f=19&t=29334

and here > viewtopic.php?f=19&t=30034

thesameguy
Level 7
Level 7
Posts: 2252
Joined: Mon Apr 18, 2005 5:06 pm
Location: Sacramento
Contact:

Re: Just got it today

Post by thesameguy » Mon Mar 07, 2016 2:24 pm

Yeah, there are two pumps - one in the tank, one under the car. TBH, on a car with an unknown history I would consider doing the Walbro swap. Buy a Walbro 255lph pump, swap it with the in-tank pump, and then delete the one under the car. It's about the same price as replacing both, and really isn't much work at all. There are numerous threads detailing the swap.

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Mon Mar 07, 2016 10:18 pm

Ok thank you. I will search for that and see if its something i want to do.
Thanks again

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Mon Mar 07, 2016 10:20 pm

I will consider the membership as well

User avatar
Mike McCreight
Level 7
Level 7
Posts: 3987
Joined: Fri Oct 31, 2003 8:44 pm
Location: Ottawa! Well, Manotick, actually...

Re: Just got it today

Post by Mike McCreight » Tue Mar 08, 2016 9:05 am

X2 on the swap. The 2 pump setup is questionable especially at 30 years. Fuel is critical at 300hp.
That'll give you a chance to see the state of the sending unit, top of the tank and the floor of the hatch. Swish the crud out of the tank too.
I had my (no winters...) tank media blasted and I coated it with truck bed liner.
Welcome aboard!
It's not a hobby, it's an obsession!

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Tue Mar 08, 2016 11:39 am

having read up on that pump I like everything I have seen. Even if I can get the old one to work again (due to a loss of 12v at the pump) I want to upgrade to the walbro pump It seems to be the only real option.

http://www.ebay.com/itm/Walbro-GSS340-O ... 6J&vxp=mtr

I found one on eBay, any thoughts?

thesameguy
Level 7
Level 7
Posts: 2252
Joined: Mon Apr 18, 2005 5:06 pm
Location: Sacramento
Contact:

Re: Just got it today

Post by thesameguy » Tue Mar 08, 2016 1:58 pm

A lot of people report success with the Chinese approximations - I don't think I've heard many failure stories. However, you can buy the real deal on Amazon for just a few bucks more:

http://www.amazon.com/WALBRO-255LPH-PRE ... B0098MC3GU

I would strongly consider spending the extra $20 for a known quantity.

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Tue Mar 08, 2016 2:09 pm

yup I agree, Thank you for the heads up. I'll let you know what happens :D

Post Reply