Just got it today

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
Merkur Club web site
User avatar
In XS 7
Level 7
Level 7
Posts: 1545
Joined: Tue Feb 21, 2012 1:29 am
Location: Kewanee, IL

Re: Just got it today

Post by In XS 7 » Thu Mar 17, 2016 12:41 pm

I would change the valve stem seals if I were you, in my XR they where very toasted, when I tried to remove them they just turn into crumbs. :cheers
Miguel.
89 XR4Ti Monique; Waking up a real "Night/Mare-Coor".
T5, NPR IC, PIMP ECU, Walbro 255, Dual piston BOV, Manual BC, 3" exhaust, One piece Aluminum drive-shaft, mc2 LSD, Boport 1.5 cam, Ported and polish head, big valves, 80# injectors, Bob's log, (soon HY35).

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Sat Mar 19, 2016 8:59 am

I was doing some reading the other day and came across an article that said to unplug the knock sensor for performance reasons. Two things, has anyone done it? and where the heck is it? I tried to look up the location with a google search and well,,, I failed.

User avatar
In XS 7
Level 7
Level 7
Posts: 1545
Joined: Tue Feb 21, 2012 1:29 am
Location: Kewanee, IL

Re: Just got it today

Post by In XS 7 » Sat Mar 19, 2016 2:43 pm

I unplug mine long time ago.
Last edited by In XS 7 on Sat Mar 19, 2016 5:15 pm, edited 1 time in total.
Miguel.
89 XR4Ti Monique; Waking up a real "Night/Mare-Coor".
T5, NPR IC, PIMP ECU, Walbro 255, Dual piston BOV, Manual BC, 3" exhaust, One piece Aluminum drive-shaft, mc2 LSD, Boport 1.5 cam, Ported and polish head, big valves, 80# injectors, Bob's log, (soon HY35).

User avatar
merkurdriver
Level 8
Posts: 6120
Joined: Tue Jan 21, 2003 4:29 pm
Location: Northeast Ohio
Contact:

Re: Just got it today

Post by merkurdriver » Sat Mar 19, 2016 3:34 pm

In XS 7 wrote:I unplug mine long time ago, it is "hanging" from the distributor, it is (in my XR, an 89') a two wires with a "plug" that just connect the two wires together.
That sounds like the SPOUT plug (connector) Miguel.

The knock sensor is a sensor in the lower intake , and yes, mine have been unplugged in ALL of my XRs for over a decade now, just make sure to always run premium fuel

User avatar
In XS 7
Level 7
Level 7
Posts: 1545
Joined: Tue Feb 21, 2012 1:29 am
Location: Kewanee, IL

Re: Just got it today

Post by In XS 7 » Sat Mar 19, 2016 5:13 pm

merkurdriver wrote:
In XS 7 wrote:I unplug mine long time ago, it is "hanging" from the distributor, it is (in my XR, an 89') a two wires with a "plug" that just connect the two wires together.
That sounds like the SPOUT plug (connector) Miguel.

The knock sensor is a sensor in the lower intake , and yes, mine have been unplugged in ALL of my XRs for over a decade now, just make sure to always run premium fuel
:oops: Yes you are right Mike, I was very sleepy when I was writing, thanks for correcting me.
Miguel.
89 XR4Ti Monique; Waking up a real "Night/Mare-Coor".
T5, NPR IC, PIMP ECU, Walbro 255, Dual piston BOV, Manual BC, 3" exhaust, One piece Aluminum drive-shaft, mc2 LSD, Boport 1.5 cam, Ported and polish head, big valves, 80# injectors, Bob's log, (soon HY35).

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Mon Mar 21, 2016 11:21 am

ordered a new breather today

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Wed Mar 23, 2016 11:13 pm

Image

Ok so I got her running I got the turn signals working but... When I give hard acceleration It builds boost but not power. In fact it feels like if I let out of the gas it gets a boost of power before it starts to drop its rpm. anyone have any idea what the issue mite be?

thesameguy
Level 7
Level 7
Posts: 2252
Joined: Mon Apr 18, 2005 5:06 pm
Location: Sacramento
Contact:

Re: Just got it today

Post by thesameguy » Thu Mar 24, 2016 1:11 pm

I'd check ignition timing first, then cam timing, then check fuel pressure. :)

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Thu Mar 24, 2016 4:16 pm

Ok I'll start with those, thanks for the suggestion

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Sat Mar 26, 2016 10:54 pm

Thank you again, it was 20* off on the timing, and now she runs like a champ.

MercMike
Level 3
Level 3
Posts: 230
Joined: Mon Oct 08, 2012 11:25 pm

Re: Just got it today

Post by MercMike » Sun Mar 27, 2016 7:04 pm

I am enjoying your work.
I would like to suggest two things.
1. Make sure your chassis/engine ground(s) are GOOD
2. Get it running well "as is" then change / add performance. A good tune in a baseline configuration may save you many headaches ?
And good luck ! :wink:
'85 XR

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Sun Mar 27, 2016 9:56 pm

Hey thanks I really appreciate the support. I will absolutely look at the grounds.

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Wed Mar 30, 2016 8:46 am

I have been driven her all around and could no be happier. I ordered this

Image

went and picked up all the brake parts today to do the upgraded front brakes. (anyone thats new iris trying this and need info on it, mc2 has a link on their page that gives you a list of what you'll need and how to.)

I notice something the other day too, after I have been driving the car for a while when ever I sit at idle it smokes. Not while driving and not when she's cold. It doesn't really smell like oil either? Anyone ever had this happen?

User avatar
In XS 7
Level 7
Level 7
Posts: 1545
Joined: Tue Feb 21, 2012 1:29 am
Location: Kewanee, IL

Re: Just got it today

Post by In XS 7 » Wed Mar 30, 2016 4:22 pm

In XS 7 wrote:I would change the valve stem seals if I were you, in my XR they where very toasted, when I tried to remove them they just turn into crumbs. :cheers
This fixed on my XR.
Miguel.
89 XR4Ti Monique; Waking up a real "Night/Mare-Coor".
T5, NPR IC, PIMP ECU, Walbro 255, Dual piston BOV, Manual BC, 3" exhaust, One piece Aluminum drive-shaft, mc2 LSD, Boport 1.5 cam, Ported and polish head, big valves, 80# injectors, Bob's log, (soon HY35).

abomb1982
Level 2
Level 2
Posts: 114
Joined: Sat Mar 05, 2016 3:46 pm

Re: Just got it today

Post by abomb1982 » Thu Mar 31, 2016 11:50 am

I have those seals on order, I should have listened the first time :roll: Oh well live and learn. Should I do the seats too?

Side note I have been shopping IC too, I was Thinking a FMIC but it looks like if i do that I have to get rid of my a/c. So here are my questions, can i have it all? a/c and a good IC. Are there folks out there that have a/c that is working. ( at this time mine does not)

Post Reply