Anyone DD theirs?

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
User avatar
Rocky's Wrench
Level 4
Level 4
Posts: 367
Joined: Sat Feb 24, 2007 8:32 pm
Location: Now in Ocean Shores, Wa...

Re: Anyone DD theirs?

Post by Rocky's Wrench » Fri Nov 02, 2018 10:38 pm

John Brennan wrote:
Mon Sep 10, 2018 3:59 pm
The only grounds I've added have been taillight matrices-to-body ground-- they pop up as an issue in lots of these cars. I would do it to any XR I own. The rest were matters of repair and maintenance, at least for me.
Part of the problem is the wire gauge used in the stock configuration isn't adequate for all the bulbs... So what happens when you have
too many amps for the wire??
SteveL
Orphan Addict...

User avatar
Rocky's Wrench
Level 4
Level 4
Posts: 367
Joined: Sat Feb 24, 2007 8:32 pm
Location: Now in Ocean Shores, Wa...

Re: Anyone DD theirs?

Post by Rocky's Wrench » Fri Nov 02, 2018 10:46 pm

Yes, I daily drive mine, which I got 6 months ago. After it sat in a field for 4 years. The day I bought it, we
stuck a battery in it, fired it up on 4+year old gas, and drove it around the block. Two weeks later, after a
new timing belt, an oil change, fresh coolant, and an accessory belt, It attended the 2018 Olympus Rally.
I've daily driving it since then...
SteveL
Orphan Addict...

User avatar
John Brennan
Level 8
Posts: 11519
Joined: Wed Jun 18, 2003 4:19 pm
Location: Scottsdale, AZ "Summer Is Coming"

Re: Anyone DD theirs?

Post by John Brennan » Sat Nov 03, 2018 8:12 am

Rocky's Wrench wrote:
Fri Nov 02, 2018 10:38 pm
John Brennan wrote:
Mon Sep 10, 2018 3:59 pm
The only grounds I've added have been taillight matrices-to-body ground-- they pop up as an issue in lots of these cars. I would do it to any XR I own. The rest were matters of repair and maintenance, at least for me.
Part of the problem is the wire gauge used in the stock configuration isn't adequate for all the bulbs... So what happens when you have
too many amps for the wire??
Well, if something's going to happen, years and years later, I'm still waiting on it. Nothing ever has. What do you suggest?
This is my car, and these are my people!
1989 XR4Ti 5-Speed
2001 BMW Z3 3.0 5-Speed
2015 Fiesta ST 6-Speed
2015 Edge 3.5 V6 Auto/Paddles

User avatar
Rocky's Wrench
Level 4
Level 4
Posts: 367
Joined: Sat Feb 24, 2007 8:32 pm
Location: Now in Ocean Shores, Wa...

Re: Anyone DD theirs?

Post by Rocky's Wrench » Sat Nov 03, 2018 12:14 pm

John Brennan wrote:
Sat Nov 03, 2018 8:12 am
Rocky's Wrench wrote:
Fri Nov 02, 2018 10:38 pm
John Brennan wrote:
Mon Sep 10, 2018 3:59 pm
The only grounds I've added have been taillight matrices-to-body ground-- they pop up as an issue in lots of these cars. I would do it to any XR I own. The rest were matters of repair and maintenance, at least for me.
Part of the problem is the wire gauge used in the stock configuration isn't adequate for all the bulbs... So what happens when you have
too many amps for the wire??
Well, if something's going to happen, years and years later, I'm still waiting on it. Nothing ever has. What do you suggest?
You've already taken care of the problem, by adding the ground...
SteveL
Orphan Addict...

User avatar
John Brennan
Level 8
Posts: 11519
Joined: Wed Jun 18, 2003 4:19 pm
Location: Scottsdale, AZ "Summer Is Coming"

Re: Anyone DD theirs?

Post by John Brennan » Sat Nov 03, 2018 3:08 pm

Rocky's Wrench wrote:
Sat Nov 03, 2018 12:14 pm
John Brennan wrote:
Sat Nov 03, 2018 8:12 am
Rocky's Wrench wrote:
Fri Nov 02, 2018 10:38 pm


Part of the problem is the wire gauge used in the stock configuration isn't adequate for all the bulbs... So what happens when you have
too many amps for the wire??
Well, if something's going to happen, years and years later, I'm still waiting on it. Nothing ever has. What do you suggest?
You've already taken care of the problem, by adding the ground...
Ah, got it! I misunderstood!🍻
This is my car, and these are my people!
1989 XR4Ti 5-Speed
2001 BMW Z3 3.0 5-Speed
2015 Fiesta ST 6-Speed
2015 Edge 3.5 V6 Auto/Paddles

User avatar
eaton53
Level 5
Level 5
Posts: 521
Joined: Wed May 06, 2015 6:08 am
Location: Silvis, IL

Re: Anyone DD theirs?

Post by eaton53 » Sat Nov 03, 2018 3:51 pm

As of 10am today mine's in storage until the end of March, so obviously not.
There's a chance of a wintry mix at the end of next week, so it's put away just in time.

Car show season starts at the end of April, so come on Springtime!
Mark Copeland - I'm 50 miles west of Kewanee, IL

'89 XR4Ti
Car was the 2014 MCA Merkur Preservation Award Winner
I'm just the latest caretaker and I'm keepin' it REAL shiny!! 8)

Ed Lijewski
Level 8
Posts: 7154
Joined: Thu Sep 04, 2003 5:53 pm
Location: The Belly of The Beast

Re: Anyone DD theirs?

Post by Ed Lijewski » Sat Nov 03, 2018 6:25 pm

John Brennan wrote:
Sat Nov 03, 2018 3:08 pm
Rocky's Wrench wrote:
Sat Nov 03, 2018 12:14 pm
John Brennan wrote:
Sat Nov 03, 2018 8:12 am

Well, if something's going to happen, years and years later, I'm still waiting on it. Nothing ever has. What do you suggest?
You've already taken care of the problem, by adding the ground...
Ah, got it! I misunderstood!🍻
The weaker and more common failure prone section(s) is inside the harness connector.

YMMV
Descartes: "Cogito Ergo Sum"
Lijewski: "Sum Ergo Drive-O. Mucho!

trueblue1968
Level 2
Level 2
Posts: 110
Joined: Tue Oct 10, 2006 7:17 pm

Re: Anyone DD theirs?

Post by trueblue1968 » Thu Jan 03, 2019 3:43 pm

once upon a time.....
Next iteration Not so much.... :twisted:
TOO MUCH IS NEVER ENOUGH!........
....More to come :twisted:

User avatar
John Brennan
Level 8
Posts: 11519
Joined: Wed Jun 18, 2003 4:19 pm
Location: Scottsdale, AZ "Summer Is Coming"

Re: Anyone DD theirs?

Post by John Brennan » Thu Jan 03, 2019 4:30 pm

Ed Lijewski wrote:
Sat Nov 03, 2018 6:25 pm
John Brennan wrote:
Sat Nov 03, 2018 3:08 pm
Rocky's Wrench wrote:
Sat Nov 03, 2018 12:14 pm


You've already taken care of the problem, by adding the ground...
Ah, got it! I misunderstood!🍻
The weaker and more common failure prone section(s) is inside the harness connector.
That happened to me in 50% of the XR's I had for a long time. The ground issue, 100% (won't count the one I got new and only had for seven years). I don't know what qualifies it as weaker, or more common. :dunno

Absolutely worth checking 100% of the time, nevertheless. :cheers
This is my car, and these are my people!
1989 XR4Ti 5-Speed
2001 BMW Z3 3.0 5-Speed
2015 Fiesta ST 6-Speed
2015 Edge 3.5 V6 Auto/Paddles

Ed Lijewski
Level 8
Posts: 7154
Joined: Thu Sep 04, 2003 5:53 pm
Location: The Belly of The Beast

Re: Anyone DD theirs?

Post by Ed Lijewski » Thu Jan 03, 2019 6:49 pm

The female spring connectors weaken over time. The male prongs accrete crud. Bulb contacts lose solder and grip.

Each and all are weaker and common failure prone points.

YMMV
Attachments
20150525_115939-512x288.jpg
20150525_115939-512x288.jpg (25.92 KiB) Viewed 1468 times
20150518_065214-640x360.jpg
20150518_065214-640x360.jpg (56.69 KiB) Viewed 1468 times
IMG_20150518_065713-816x612.jpg
IMG_20150518_065713-816x612.jpg (70.44 KiB) Viewed 1468 times
Descartes: "Cogito Ergo Sum"
Lijewski: "Sum Ergo Drive-O. Mucho!

Post Reply