Power mirrors

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
Post Reply
Merkur Club web site
mikerobison
Level 2
Level 2
Posts: 186
Joined: Tue Sep 26, 2006 10:20 am
Location: Spokane,Wa
Contact:

Power mirrors

Post by mikerobison »

Does anyone have power mirrors that work? Every XR I have gotten into the mirrors don't work. Where are the weak spots? and are there replacement parts?
jasonty
Level 6
Level 6
Posts: 826
Joined: Tue Jan 14, 2003 10:23 pm
Location: stephens city va
Contact:

Post by jasonty »

check the fuse. i works other functions also.
jason yancey
stephens city va
87XR-88XR
NOVAMOG



"as long as you keep picking on me I will tend to mad post about me getting mad......"
User avatar
DPDISXR4Ti
Site Admin
Posts: 13787
Joined: Wed Jan 08, 2003 11:40 pm
Location: New York

Post by DPDISXR4Ti »

Must be a PacWest thing - all the ones back east here work fine. :lol:

Seriously though, mine have allways worked and I've never heard of this being a problem. Since you're suggesting that both sides aren't working, I'd be checking the overall circuit integrity as Jason suggested.
Brad
User avatar
John Brennan
Level 8
Posts: 11630
Joined: Wed Jun 18, 2003 4:19 pm
Location: Scottsdale, AZ "Summer Is Coming"

Post by John Brennan »

None of my Merk mirrors ever failed in sixteen years of ownership. I wouldn't say they're prone to trouble. It shouldn't be too hard to figure out.
This is my car, and these are my people!
1989 XR4Ti 5-Speed
2001 BMW Z3 3.0 5-Speed
2015 Fiesta ST 6-Speed
2015 Edge 3.5 V6 Auto/Paddles
DereX
Level 2
Level 2
Posts: 132
Joined: Mon Feb 21, 2005 4:30 am
Location: Federal Way, Washington

Post by DereX »

cant be pacwest thing mine work on both cars
Derek Stout
age: 21
Federal Way, WA

mono black 86 manual - Dead Motor
grey clad red 85 manual, sunroof - No Turbo
Red 99 MX-5 - Stock Daily Driver
jasonty
Level 6
Level 6
Posts: 826
Joined: Tue Jan 14, 2003 10:23 pm
Location: stephens city va
Contact:

Post by jasonty »

mine have failed many times. and as far as i can remember it was a fuse that also served the heated seats. i finally had to adjust the contacts in the fuse box
DPDISXR4Ti wrote:Must be a PacWest thing - all the ones back east here work fine. :lol:

Seriously though, mine have allways worked and I've never heard of this being a problem. Since you're suggesting that both sides aren't working, I'd be checking the overall circuit integrity as Jason suggested.
jason yancey
stephens city va
87XR-88XR
NOVAMOG



"as long as you keep picking on me I will tend to mad post about me getting mad......"
User avatar
l39_pilot
Level 2
Level 2
Posts: 137
Joined: Fri Dec 22, 2006 10:55 pm
Location: SE Michigan

Post by l39_pilot »

Mine dont work except for 1 side in 1 direction. Fuses are all good. Havent tried to tear them apart yet. Suggestions?
'85 XR4Ti 135k
User avatar
Mike McCreight
Level 7
Level 7
Posts: 3987
Joined: Fri Oct 31, 2003 8:44 pm
Location: Ottawa! Well, Manotick, actually...

?

Post by Mike McCreight »

Yup.
Same as most window problems. Clean or replace the switch. It's in a BAD spot for condensation.
It's not a hobby, it's an obsession!
mikerobison
Level 2
Level 2
Posts: 186
Joined: Tue Sep 26, 2006 10:20 am
Location: Spokane,Wa
Contact:

Post by mikerobison »

Yes, the fuse that controls the heated seats also controls the power mirrors.
Frag
Level 7
Level 7
Posts: 2256
Joined: Fri Oct 17, 2003 12:41 am
Location: Seattle, Wa
Contact:

Post by Frag »

Mine work fine *shrug*
:)
GogetaXR4
Newbie
Newbie
Posts: 14
Joined: Sat Mar 29, 2008 4:51 pm
Location: Buenos Aires, Argentina

Post by GogetaXR4 »

Hi all!
How many apms is the fuse for the power mirrors/heated seats? Does it protect anything else?
I have a standalone installation for the power mirrors (no heated seats), and I need to add a fuse, and I don't know how many amps should I use.
Thanks!

PS: since the question is related, I didn't want to start a new topic
User avatar
ALConfederate
Level 4
Level 4
Posts: 373
Joined: Thu May 29, 2008 10:40 pm
Location: Hueytown, AL
Contact:

Post by ALConfederate »

IIRC it's a 30A fuse. The little diagram in your fuse box lid will tell you for sure. (You DO have a lid, right?)
Dave M.
'89 XR4Ti "The Black Death"
('cause it's black and spends a lot of time dead...)
GogetaXR4
Newbie
Newbie
Posts: 14
Joined: Sat Mar 29, 2008 4:51 pm
Location: Buenos Aires, Argentina

Post by GogetaXR4 »

Thanks Dave.
I do have a lid, but I don't have a Merkur (it's a Sierra and it doesn't have power mirrors from factory), so the lid is of no help in this case.
User avatar
ALConfederate
Level 4
Level 4
Posts: 373
Joined: Thu May 29, 2008 10:40 pm
Location: Hueytown, AL
Contact:

Post by ALConfederate »

Oh! Well, in that case we need to find you an XR to go with your lid, now don't we? :)
Dave M.
'89 XR4Ti "The Black Death"
('cause it's black and spends a lot of time dead...)
GogetaXR4
Newbie
Newbie
Posts: 14
Joined: Sat Mar 29, 2008 4:51 pm
Location: Buenos Aires, Argentina

Post by GogetaXR4 »

Just FYI, I used a 5A fuse to protect ONLY the power mirrors and no problem so far (I do have a 10A in case this one blows up :) ). I still need to hook up the mirror heaters, but that's going to be a little more complicated.
Thanks!
Post Reply