Shaky

XR4Ti / Sierra / Sierra Cosworth Discussions - Questions, problem resolution, general talk, technical tips and modifications.
Post Reply
hotrodtodd68
Level 2
Level 2
Posts: 129
Joined: Fri Mar 14, 2008 9:39 am
Location: Colchester, CT
Contact:

Shaky

Post by hotrodtodd68 » Fri May 17, 2019 10:47 am

Hey guys. It looks like you’re still here. What do you think this shaky shaky is?
https://youtu.be/o70esX4BMaM
https://youtu.be/oB6xmeDQbOc
https://youtu.be/UaSGyZyTcbU
Last edited by hotrodtodd68 on Fri May 17, 2019 7:35 pm, edited 1 time in total.
88 2.3T Mustang, 85 XR4Ti("Humpty-Dumpty"), 86 XR4Ti(someday project), 02 Wrangler Sport, 68 Firebird(red,fun), 71 GMC1500(dumprunner), 93 Geo Storm GSi ("Stitch"), 65 Mustang Convertible, 12 Dodge Challenger R/T ("the fast car"), 12 Toyota Highlander ("the lux-o-barge")

my8950
Level 6
Level 6
Posts: 803
Joined: Wed Jan 19, 2005 11:07 pm
Location: Detroit

Re: Shaky

Post by my8950 » Fri May 17, 2019 2:38 pm

I think its not available....

hotrodtodd68
Level 2
Level 2
Posts: 129
Joined: Fri Mar 14, 2008 9:39 am
Location: Colchester, CT
Contact:

Re: Shaky

Post by hotrodtodd68 » Fri May 17, 2019 7:36 pm

I fixed the links. Apparently Facebook links don’t work.
88 2.3T Mustang, 85 XR4Ti("Humpty-Dumpty"), 86 XR4Ti(someday project), 02 Wrangler Sport, 68 Firebird(red,fun), 71 GMC1500(dumprunner), 93 Geo Storm GSi ("Stitch"), 65 Mustang Convertible, 12 Dodge Challenger R/T ("the fast car"), 12 Toyota Highlander ("the lux-o-barge")

User avatar
andyofcolumbusmerkur
Level 4
Level 4
Posts: 335
Joined: Mon Jul 15, 2013 7:58 pm

Re: Shaky

Post by andyofcolumbusmerkur » Sat May 18, 2019 9:01 am

It looks like you found the problem while it was on the lift.
You're only as good as the last car you build.

my8950
Level 6
Level 6
Posts: 803
Joined: Wed Jan 19, 2005 11:07 pm
Location: Detroit

Re: Shaky

Post by my8950 » Sat May 18, 2019 11:01 am

Looks like you're wiggling something...What was the issue?

Ed Lijewski
Level 8
Posts: 7173
Joined: Thu Sep 04, 2003 5:53 pm
Location: The Belly of The Beast

Re: Shaky

Post by Ed Lijewski » Sat May 18, 2019 2:13 pm

Worn inner tie rod ball joint.

YMMV
Descartes: "Cogito Ergo Sum"
Lijewski: "Sum Ergo Drive-O. Mucho!

User avatar
Merkurstein
Newbie
Newbie
Posts: 11
Joined: Tue Sep 18, 2018 3:49 pm
Location: Oneida, Tennessee

Re: Shaky

Post by Merkurstein » Sat May 18, 2019 5:48 pm

Yeah tie rods needed for sure! Just changed mine too. Has the tires been setting for awhile?

hotrodtodd68
Level 2
Level 2
Posts: 129
Joined: Fri Mar 14, 2008 9:39 am
Location: Colchester, CT
Contact:

Re: Shaky

Post by hotrodtodd68 » Sat May 18, 2019 11:04 pm

yeah thanks maybe it is the inner tie rod ends
The tires had been sitting which might make it worse but I had this problem before I parked it. It’s weird like it’s worse under load like going uphill. I checked the guibo and it’s ok too.
88 2.3T Mustang, 85 XR4Ti("Humpty-Dumpty"), 86 XR4Ti(someday project), 02 Wrangler Sport, 68 Firebird(red,fun), 71 GMC1500(dumprunner), 93 Geo Storm GSi ("Stitch"), 65 Mustang Convertible, 12 Dodge Challenger R/T ("the fast car"), 12 Toyota Highlander ("the lux-o-barge")

my8950
Level 6
Level 6
Posts: 803
Joined: Wed Jan 19, 2005 11:07 pm
Location: Detroit

Re: Shaky

Post by my8950 » Sun May 19, 2019 9:13 pm

Hmmmm, this actually makes me wonder if mine has the same issue.
Mine is nowhere near this bad, only does it when I brake.
Front brakes are new, tie rod ends are new, but still does.
I was thinking control arm bushings, but maybe inner tie rod ends?

Post Reply